Beim Update von Debian 5.0 Lenny auf Debian 6.0 Squeeze erscheint im Laufe des apt-get dist-upgrade Prozesses oft die Fehlermeldung "Unable to migrate to dependency-based boot system".

Die Ursache ist hier zumeist das libdevmapper-Library, das nicht mehr benötigt wird aber den Wechsel des Bootsystems blockiert. Einfach entfernen (--purge) und dann dann die Umstellung mittels dpkg-reconfigure fortsetzen.

dpkg --purge 5libdevmapper1.02
dpkg-reconfigure sysv-rc

Hinweis: dieser Artikel ist ursprünglich auf dem IT-Blog "copy/paste" (www.copypaste.at) erschienen.

apt-show-versions: magic number checking on storable file failed

apt-show-versions ist ein praktisches Perl-Skript im Zusammenhang mit der Verwaltung der .deb Pakete mittels apt, z.B. zum schnellen herausf…… Continue reading

Piwik 0.2.31

Published on March 02, 2009

Logitech's neuer Squeezebox Server 7.5.3

Published on January 25, 2011