apt-show-versions ist ein praktisches Perl-Skript im Zusammenhang mit der Verwaltung der .deb Pakete mittels apt, z.B. zum schnellen herausfinden von Paketen die ein Upgrade benötigen (apt-show-versions | grep upgrade). Liefert das Skript allerdings einen "Magic number"-Fehler, ist höchstwahrscheinlich eine Cache-Datei nicht in Ordnung, der Fehler kann mittels Löschung der Datei ganz einfach behoben werden.

root@host:~# apt-show-versions
Magic number checking on storable file failed at ../../lib/Storable.pm (autosplit into ../../lib/auto/Storable/_retrieve.al) line 380, at /usr/bin/apt-show-versions line 188

root@host:~# cd /var/cache/apt-show-versions/

root@host:/var/cache/apt-show-versions# ls -lai
total 7268
629586 drwxr-xr-x  2 root root    4096 2011-10-05 23:19 .
351573 drwxr-xr-x 20 root root    4096 2011-06-22 17:58 ..
629570 -rw-r--r--  1 root root 7173643 2011-10-05 23:19 apackages
629568 -rw-r--r--  1 root root       0 2011-10-08 12:21 files
629569 -rw-r--r--  1 root root  241229 2011-10-05 23:19 ipackages

root@host:/var/cache/apt-show-versions# rm files

root@host:/var/cache/apt-show-versions# apt-show-versions | less

root@host:/var/cache/apt-show-versions# ls -lai
total 7340
629586 drwxr-xr-x  2 root root    4096 2011-10-08 12:23 .
351573 drwxr-xr-x 20 root root    4096 2011-06-22 17:58 ..
629570 -rw-r--r--  1 root root 7244491 2011-10-08 12:24 apackages
629568 -rw-r--r--  1 root root    1861 2011-10-08 12:23 files
629569 -rw-r--r--  1 root root  241229 2011-10-05 23:19 ipackages

root@host:/var/cache/apt-show-versions#

Hinweis: dieser Artikel ist ursprünglich auf dem IT-Blog "copy/paste" (www.copypaste.at) erschienen.

Debian Squeeze-Update: Fehler "Unable to migrate to dependency-based boot system"

Beim Update von Debian 5.0 Lenny auf Debian 6.0 Squeeze erscheint im Laufe des apt-get dist-upgrade Prozesses oft die Fehlermeldung "Unable …… Continue reading